Blogged by Ujihisa. Standard methods of programming and thoughts including Clojure, Vim, LLVM, Haskell, Ruby and Mathematics written by a Japanese programmer. github/ujihisa

Thursday, April 23, 2009

Now Rubygems Can Generate a Graph

RubyGems 1.3.2 now has plugins feature. The gem plugins feature is like subcommands of git, and is able to be added easily.

For example, rubygems can show a dependency graph of installed gem packages. Let's try!

$ sudo gem update --system
$ sudo gem install graph
$ gem graph

An error occured. I need graphviz library. OK.

$ sudo port install graphviz
--->  Fetching urw-fonts
--->  Attempting to fetch urw-fonts-1.0.7pre44.tar.bz2 from
--->  Verifying checksum(s) for urw-fonts
--->  Extracting urw-fonts
--->  Configuring urw-fonts
--->  Building urw-fonts
--->  Staging urw-fonts into destroot
--->  Installing urw-fonts @1.0.7pre44_0
--->  Activating urw-fonts @1.0.7pre44_0
--->  Cleaning urw-fonts
--->  Fetching graphviz
--->  Attempting to fetch graphviz-2.22.2.tar.gz from
--->  Verifying checksum(s) for graphviz
--->  Extracting graphviz
Error: On Mac OS X 10.5, graphviz 2.22.2 requires Xcode 3.1.2 or later but you have Xcode 3.1.
Error: Target org.macports.extract returned: incompatible Xcode version
Error: Status 1 encountered during processing.


No comments:

Post a Comment